2

Just upgraded rollup helper to v6.39 and now I can't insert/update/delete any standard objects. All the rollup helper tabs produce a similar error. Reaching out to support at passage tech, anyone else having this issue and gotten a solution?

Never wished I could roll back a managed package install worse than this.

Error on Account Insert

System.DmlException: Insert failed. First exception on row 0; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, rh2.PS_Account: execution of AfterInsert caused by: System.TypeException: Invalid conversion from runtime type rhx.RHX_Describe_Helper1 to rh2.PS_DescribeHelper4 (rh2) : []

Error on PS Describe Delete

System.DmlException: Delete failed. First exception on row 0 with id a4h500000004ClqAAE; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, rh2.PS_Describe: execution of AfterDelete caused by: System.TypeException: Invalid conversion from runtime type rhx.RHX_Describe_Helper1 to rh2.PS_DescribeHelper4 (rh2) : []

Error on Rollup Helper Tab

Invalid conversion from runtime type rhx.RHX_Describe_Helper1 to rh2.PS_DescribeHelper4 Error is in expression '{! numActive }' in component <apex:page> in page rh2:ps_allsettings: (rh2)

2
  • You sure you don't have the same package installed twice with different namespaces? Maybe just remove and then install fresh? Commented Sep 4, 2014 at 5:53
  • @Bachovski rh2 is the core package (Rollup Helper), rhx is the extension (Rollup Helper Real Time). Only option looks like uninstalling everything, it's just a mess since we have a lot of references to this, a lot of data which doesn't appear to be stored in their custom objects. To make things even more fun, the extension package is a paid addition, and there is no public install url. So going for the long shot before having to spend all day uninstalling and reinstalling the package. Long shot isn't looking good. Commented Sep 4, 2014 at 5:57

1 Answer 1

3

There was an issue mismatch between the Rollup Helper core (rh2) and Rollup Helper Realtime (rhx) packages. Support provided the following links for installing the latest versions of both packages.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .