17

I recently started using the new Force.com IDE plugin (in Eclipse Kepler). Since that happened, today I looked in the Setup Audit Trail log and was shocked to see that against my name there have been over 50,000 code changes in the last few days!

It appears that whenever I edit & save a single file from the IDE, somehow 100% of the code gets a "Changed XXX Apex Class code" event logged against it, even though a diff shows that nothing actually changed in the files I didn't edit. This seems impossible, since the saves only take 1-2 seconds max.

Has anybody seen this, and can anybody shed light on how to prevent it? Or if it is caused by the Force.com IDE, or possibly a Tooling API or platform bug? It's a huge annoyance and quite disturbing to my client's admin team :)

11
  • 1
    I don't see this in the IDE bug list github.com/forcedotcom/idecore/issues. Flagging it there would probably get it looked at whether the cause is in the IDE or not. – Keith C Aug 29 '14 at 7:34
  • Very strange. I have updated to the Summer '14 version (31.0.0.201406301722) and it is defaulted to "Work Offline". So every save takes about 7-8 seconds and I need to confirm the save dialogue 2 times. Just checked the audit trail and there is nothing special. – Sergej Utko Aug 29 '14 at 7:37
  • 2
    @DavinC It can happen if you selects the whole project or "src" folder (accidentally) and then do "Save to Server". That's why it is a good idea to set the "Link with Editor" button on (Package explorer). – Sergej Utko Aug 29 '14 at 8:24
  • 1
    I think you should use mavensmate plugin in sublime text editor for your salesforce project instead of force.com plugin in eclipse . – upgoingstar Nov 28 '14 at 8:23
  • 1
    I have seen this for years, and was never really able to come up with a reproducible scenario to cause it to happen. I think it was related to when the IDE did not close gracefully... – Ray Dehler Jul 25 '15 at 17:36
1

I had seen this before.
Eclipse Force.com IDE may deploy the whole project after it crashed and restarted.Not allways but there has this risk.I don't sure that it is IDE's bug.

I recommend you to use Sublime Text3 instead of Eclipse,it is awesome.
Reference the following page and you can easily setup it.
Setup an awesome Salesforce developer environment with Sublime Text 3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.