5

I am trying to opt-out of SMS using QueueMO API but getting error. Below is the request and response. Any idea what could be going wrong? Is there any other way to opt-out using REST API? Thanks in Advance.

endpoint - https://www.exacttargetapis.com/sms/v1/queueMO Method - POST

Request : 

{
  "mobileNumbers": [
    "12405517333"
  ],
  "shortCode": "88769",
  "messageText": "STOP"
}

Response :
{
    "errors": [
        "Client, ShortCode, Keyword combination is invalid."
    ]
}
  • What happens when you don't have the preceding "1" on the mobile number? Same thing? – Timothy Aug 12 '14 at 19:15
  • yes same thing. – Ashwin Aug 13 '14 at 21:19
  • Do you have any Text Response or Mobile Opt-In messages set up for that particular short code? – Alex Finger Aug 22 '14 at 14:32
  • Please find the Summary below TEMPLATE TYPE Mobile Opt-In SHORT/LONG CODE 88769 KEYWORD MOZIDO_TEST CAMPAIGN ASSOCIATIONS -- Messages EXTERNAL SOURCE Text 'MOZIDO_TEST' to 88769. SUBSCRIPTION OPTIONS Double Opt-in OUTBOUND RESPONSE Thanks for subscribing! Please respond with y to confirm your subscription. OUTBOUND CONFIRMATION Thanks for subscribing! You will receive approx 20 message(s) per Week. StartSaturday, August 09, 2014 2:05 PM EndNever Time Zone(GMT-06:00) Central Time (US & Canada) * ERROR RESPONSE Sorry, there was an error. Please try again. – Ashwin Aug 25 '14 at 13:20
  • 1
    same issue here. – Andre Leoni Feb 1 '19 at 21:40
0

It looks like you have a placeholder/sample shortcode; assuming you are swapping this out when making the call, if this is a new shortcode that has not completed carrier review, it is likely the STOP keyword is not configured in the UI.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.