3

We are creating a managed package, which recently passed the received security review, and have had no issues installing it in DE and EE orgs...until today. Today, installs are failing in production and sandbox EE and Perf. Edition orgs with the following hard-to-comprehend error message.

Problem: Unable to Access Page

Component: (Product_Team)

Detail: "The value of the "{0}" parameter contains a character that is not allowed or the value exceeds the maximum allowed length. Remove the character from the parameter value or reduce the value length and resubmit. If the error still persists, report it to our Customer Support team. Provide the URL of the page you were requesting as well as any other related information."

Product_Team" is a permission set in the package. It does not define any master-detail relationships to standard objects (so I don't believe it is this issue, which I have encountered before: https://success.salesforce.com/issues_view?id=a1p30000000SbMUAA0)

Why am I getting an "unable to access page" during a package install? What is the "{0}" parameter value a reference to?

Any insight would be appreciated.

  • Can you provide the url of the page you were requesting? Or at least, everything after the domain? – Carolyn Grabill Aug 8 '14 at 21:36
  • Hi Carolyn. This error occurred during the package installation process itself, and caused the install to fail. I wasn't trying to access any page at all, which is what makes this so bizarre. – ArtieBrosius Aug 9 '14 at 3:03
  • Is this a newer version of the managed package? Do you have an older version that still installs? If so, what has changed between the older and the newer version of the managed package? – Daniel Ballinger Aug 10 '14 at 8:46
  • I tried both the old (v1.0) and new (v1.1) versions. I tried sandboxes in Summer '14 and Winter '15 in two different orgs, and two different production orgs (obviously Summer '14). Neither the new nor the old version will install. They both throw the same error. – ArtieBrosius Aug 10 '14 at 17:56
  • Some more weirdness: I logged into a Partner DE org that had a previous beta version of the package installed. I uninstalled that, then installed the latest version of our package. Worked fine! Then I spun up a brand new (Partner) EE test org and installed the v1.1 package there. Again, worked fine. Both of these were on na17. Not sure if there are differences between orgs that is at issue, or there are instance-specific bugs? – ArtieBrosius Aug 11 '14 at 15:24
0

I wanted to update this post with what I found out. I discovered what was causing the intermittent install failure. It was the new feature available during package upload called "Post Install Instructions". If you select the "Visualforce Page" option and point to a VF page, this will cause the failure to install in some orgs. I created a patch org and uploaded a new package, making no other changes besides setting "Post Install Instructions" to "None". The resulting package installed in all the orgs in which it had previously failed.

As I wrote above, the error seems to reference a permission set, but this makes no sense. Why would the admin installing the app need a permission set to access the VF page? And even so, the permission set that is referenced has been granted access to the VF page. So the error is a red herring (or points to the platform bug).

Anyway, I would caution against using the "Post Install Instructions" feature with the "VF" option.

Frustratingly, SF support all but admitted it was a bug, but closed my case and refused to create a Known Issue out of it. They suggested I post on the developer boards, where other SF folks would take up my case. I haven't taken the time yet to do that...

  • You may want to include your case number here, there's some SFDC engineers who lurk SFSE and might prod them into accepting a bug report. – ca_peterson Sep 12 '14 at 2:21
  • Here's the Case number: 10868327. Unfortunately, the problem has now returned, but it's slightly different. I have created a new beta package and have tried installing it in a Winter '15 pre-release DE org and I'm getting the same error I reported above! And this without using the "Post Install Instructions" option. So now I'm really confused, and more than a little worried, since Winter '15 starts rolling out in a few days and I don't know what I'm facing here. – ArtieBrosius Sep 17 '14 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.