1

enter image description here

The new button for this object is overridden by a vf page. It is showing in the sf1 app for admin users but the same button is not showing up for some other non admin users in sf1. Profiles and other object related settings seems fine here. Am I missing something here ? Pls help. Available for salesforce mobile apps checkbox is true.

| improve this question | | | | |
  • And the visualforce page is accessible to regular users? – Jagular Aug 6 '14 at 13:57
  • Yes. It is accessible to them. – Tanuj Kumar Sharma Aug 6 '14 at 14:01
1

If this button is related to a publisher access, this issue can happen if non-admin profiles are not having access to the Visualforce page and/or a related Apex Class.

To verify permissions, go to Setup | Manage Users | Profiles. Then open the User Profile having the issue. Click on "Visualforce Page Access" and verify that the Profile has access to the Visualforce page being used. If it is not listed, click the Edit button and add the required Page.

If your Visualforce page uses an Apex Class, repeat these steps for "Apex Class Access".

Once this is done, test and confirm the Publisher Action is now visible to the User.

| improve this answer | | | | |
  • I have checked the page & class access ans they are fine. The new button is still not visible there. – Tanuj Kumar Sharma Aug 9 '14 at 9:52
1

Another test you can do is check if the same affected user can see the New button from the browser-based Salesforce1 app.

If it is present in the browser-based version of the app, and not in the downloadable version, then it could be related to the following Known Issue: https://success.salesforce.com/issues_view?id=a1p30000000T4veAAC

The Known Issue references a users profile with the "View Setup and Configuration" permission disabled. I have seen this issue occur with or without this permission but it is likely linked to the same issue.

The Known Issue site mentions that this should be fixed in Winter '15, however recent discussions with Support teams indicate that it will be delayed.

| improve this answer | | | | |
0

enter image description hereGo to that visualforce page and Check the "Available for Salesforce mobile apps and Lightning Pages" checkbox.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.