4

I managed to add a connected app in a sandbox instance but when I try to add one in the production instance, I receive this error.

The application name [name] / [API name] has been used before. Use a new unique name for your application.

This happens no matter what name or API name I try.

Steps to reproduce:

  1. Setup > Create > Apps > Connected Apps > New
  2. Fill out the connected app name, API name, contact email.
  3. I used OAuth settings (but tried with others and got the same problem)
  4. Save

Here's a post in their support forum of the same issue (dating back to June 2013) and there are no solutions. Some potential help has been provided but the article linked to does not work any more.

I just need to make a connected app so that I can get an API key to use the REST API with. If there is a different way of doing this, that would also be helpful.

Thanks!

  • There is a similar known issue from 7 days ago. Connected App partial copy to sandboxes, App is available in sandbox (not visible in UI). However, it does seem distinct from your issue. – Daniel Ballinger Aug 4 '14 at 9:23
  • Thanks. It's similar but still distinct. Any ideas? – Kane Aug 4 '14 at 23:21
  • I'd start with raising a support case. Other than that, a completely random name and API name? – Daniel Ballinger Aug 5 '14 at 1:13
  • I raised a support case and they just closed it directing me to the developer forums (I posted in the linked thread above). I've tried completely random names (50 char alphanumeric) and that doesn't help sadly. – Kane Aug 5 '14 at 4:28
  • Personally I think it is crazy that we can't raise a platform bug directly with Salesforce support and need to wait for them to find it in the forums. How are they going to inspect the Org to get the required details? </rant> :) Personally, I think I'd start a new support forum post and link back to the previous post. – Daniel Ballinger Aug 5 '14 at 9:08
1

This was caused by an issue on Salesforce's side. I was told that they used a "special developer tool" (how vague...) to fix it. If you encounter this problem, you will have to contact their support team to get it sorted.

Unfortunately, we had to purchase Premier Support for this solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.