I'm trying out the new Force.com IDE plugin (, under Eclipse Kepler (SR2, build 20140224-0627).

When I now save an Apex class, the class does not get automatically deployed to the server (as it used to in the older plugin). Instead, I get the "File only saved locally, not to server" marker, and have to manually right-click and select Force.com > Save to Server. This is much worse than before, not only because of the extra clicks, but I now get a popup window which blocks my UI until the deployment is over. Saving a single class also appears no faster, and maybe even slower, than it was in the old IDEE.

Under the "Project" menu, I do have "Build Automatically" checked. I also have checked all the Force.com and Project Preferences and can't find any other setting that would control this.

Is this a change in functionality, or is there some shortcut or setting I'm missing?

  • Please check the answer on [the similar question][1] [1]: salesforce.stackexchange.com/questions/11179/… Jul 25, 2014 at 4:49
  • Thanks for the tip, but that is about an older version of the plugin and the answer, "build automatically" as I noted is already checked. @Bob Buzzard's answer looks promising though!
    – jkraybill
    Jul 26, 2014 at 1:56
  • Isn't auto-deploy dangerous when logged into a production system? I just noticed that whoa... command S was saving to my sandbox and I didn't think it had that behavior. Nov 21, 2016 at 14:30

1 Answer 1


I've upgraded to this version of the plugin, and the default behaviour now when you create a new project is offline mode, which only saves files locally.

You can change this by right-clicking the project name, going to the force.com context menu and choosing the 'Work online' option:

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .