6

I'm trying to get ant to deploy successfully.

My package.xml pulls in profiles such as this:

<types>
        <members>Admin</members>
        <members>Planning Administrators</members>
        <members>Planning Officer</members>
        <members>Planning User</members>
        <members>Technical Support Officers</members>
        <name>Profile</name>
</types>

These are retrieved from a sandbox and I'm trying to deploy them to a developer org.

On deployment I get these error messages:

All Component Failures:
1.  profiles/Admin.profile -- Error: Unknown user permission: DataExport
2.  profiles/Planning Officer.profile -- Error: Unknown user permission: EditPublicReports
3.  profiles/Planning Administrators.profile -- Error: Unknown user permission: EditPublicReports
4.  profiles/Technical Support Officers.profile -- Error: Unknown user permission: EditPublicReports

Are these new permissions introduced in an org update? How can I deploy these profiles?

Paul

  • Any updates on this? I'm trying to migrate from production to sandbox and getting the same thing: profiles/System Developer.profile -- Error: Unknown user permission: EditBillingInfo (line 0) – Xtremefaith Jan 13 '15 at 18:32
  • @Xtremefaith I'm guessing EditBillingInfo corresponds to this: help.salesforce.com/…. This permission doesn't exist in a sandbox because you can't purchase salesforce licenses from a sandbox. Solns: 1) Changeset from Production to Sandbox. 2) Refresh sandbox. 3) Cherrypick profile data. – powlo Jan 15 '15 at 10:16
2

The "Error: Unknown user permission: EditPublicReports" is because you have sharing report and dashboard folders switched on.

There are two solutions depending on whether you want this controlled at prolfile level or not.

Either:

  1. Remove the EditPublicReports option from the XML
  2. Go to Setup-> App Setup-> Reports & Dashboards->Folder Sharing and untick this option
1

This is not uncommon when deploying between different Salesforce environments.

The target org that you are deploying to does not support these features.

To resolve the error you can simply remove the XML node from the profiles and re-run your deploy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.