2

I am following the steps in http://peterknolle.com/live-agent-pre-chat-api/ to setup a pre-chat form that will allow the system to capture information about the person, the agent is going to chat with.

  • I have got the Live Agent Deployment with the option to access pre-chat api checked and enter the permitted domains.
  • I have the button configured to use a pre-chat page
  • I have created http://jsfiddle.net/deepuchacko/nJShf/3/ that hosts the deployment and button code.
  • I am part of the Skills

Even though I have logged into the org as Agent and made myself Online on Live Agent, the jsfiddle keeps showing Offline. I know this is not right because I have another button configuration that does not have a pre-chat form and the http://jsfiddle.net/deepuchacko/nJShf/1/ for it shows as Online. Any thoughts on why the system might think the agents are offline?

3
  • Have you tried this from a local file or a visualforce page?
    – PepeFloyd
    Jul 10, 2014 at 12:34
  • @PepeFloyd I have tried this from a local file and still the page shows that am offline (same behavior as described above). With all the googling, I noticed that you and PeterKnolle are two people who have been successful in getting LiveAgent to work with pre-chat forms. Unfortunately following the dev guide and peter's article has not been fruitful.
    – DCBoy
    Jul 10, 2014 at 13:56
  • There are a lot of reasons the button could be offline. Have you tried enabling debug logs on your deployment page? Adding liveagent.enableLogging(); before the init call, and before calling any other Live Agent APIs, often results in useful information being output to the JS console. Jul 11, 2014 at 20:18

1 Answer 1

1

I had a few domains set in the Permitted Domains field of Deployment (Setup -> Customize -> Live Agent -> Deployments). Once I removed the domains, my status as well as the pre-chat form popped up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .