5

We have a basic lightning web component that allows guest user to upload file through a public site on Salesforce for couple of our customers. Starting from this morning we noticed Summer 24 orgs that have Patch 9 are having an issue saying Can't upload filename.

<lightning-file-upload
                name="UploadFile"
                record-id={relatedRcId}
                file-field-name="Guest_User_fileupload__c"
                file-field-value={relatedRecordId}
                onuploadfinished={handleUploadFinished}
                disabled={isDisabled}
                >
            </lightning-file-upload>

enter image description here

From the dev console error message shows 400 Bad Request to a chatter endpoint.

The same component is working for logged in users in the affected orgs so I am thinking there is a permission/sharing issue somehow. But even removing related record id the error stil persists.

What I checked?

  1. Guest user has permission to the record
  2. File upload is enabled for guest users
  3. Issue is not happening for Summer 24 Patch 8.6 or Spring 24 orgs
  4. There is no Apex log so file upload fails before a log file can be generated.
  5. Remove record-id and file- attributes to see if guest user can upload the file without relating it to a record

Does anyone have a solution for this problem?

PS. I also opened a case with Salesforce and I am waiting a response.

3
  • 1
    FYI - Getting the same error using the file upload component in a flow. Will also raise a case Commented Jun 13 at 12:50
  • 1
    FYI Same issue starting today, going to open the case
    – azimut3
    Commented Jun 13 at 13:09
  • We have a same problem for screen flow in our Experience Cloud Site(Aura). It was uploading files successfully before the Summer Release but It's not working now. Commented Jun 14 at 3:50

2 Answers 2

3

This has been flagged as a bug, and there is now a Known Issue: https://issues.salesforce.com/issue/a028c00000zJ3Mk/lightning-file-upload--guest-user-file-upload-fails

1
  • 1
    Thanks for sharing this.
    – tugce
    Commented Jun 13 at 20:59
0

We got the same error too. If you inspect the page, it is referencing a Chatter API. You will have to go into setup>all sites>Workspace>administration>Preferences> and the check the box "Give guest users access to public Chatter API requests"

After this, we refreshed the site and was able to upload again.

3
  • That's interesting, we tried that but it didn't work. I tried again just to make sure but we are still having an issue. But you are right, the error message is coming from Chatter endpoint.
    – tugce
    Commented Jun 13 at 16:31
  • I know this is true for LWR sites - but I also tried it with the Aura site on 9.2, and it still isn't working, so not sure this is the same root cause Commented Jun 13 at 17:56
  • We have primier support with salesforce. Update***We started experiencing the issue again. Salesforce confirmed with us that it is due to the summer release. They are working on a fix right now.
    – Bee Vang
    Commented Jun 13 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .