0

I have a sending data extension with an ID as the subscriber key + the email address. The issue is that when sending an email via journey builder, for some reason it's not sending the email to the correct email address but instead to an internal email within my company. This doesn't happen with all records in the data extension, but only with some. I've already checked the All Subscribers list and these are not records that existed previously (meaning, it's not picking up a wrong email address from there, they are new records). At the same time, the person who owns the internal email that is supposed to be receiving the emails, confirmed that he actually didn't receive anything, but metrics are showing that he had open the email what makes it even more weird. Does anyone know what could be happening? I've checked EVERYTHING. Thank you!

3
  • Are you referencing your contact model for obtaining the email address? If so, have you verified your email address for that contact key in your All Contacts? Commented May 9 at 12:15
  • Yes, we're getting them from Contact model, but we had deleted those records from All Contacts as well, before the sendout :(
    – malena
    Commented May 9 at 12:22
  • Can you not select the email address field from the journey source data extension instead of using the email address from the contact model? Commented May 13 at 12:22

2 Answers 2

0

If you have multiple email address type fields in the DE, it could happen that Salesforce is picking the wrong one.

In order to verify to which email address the Journey is sending to, you can go to Journey > Settings > Default Email Address: Journey Builder Default Email Address

0

We've tried everything you mentioned. We finally opened a case to support and apparently there was a bug updating the All Subscribers and All Contacts list after the send-out. To sum up: the emails are correctly sent but the tracking is getting the wrong emails.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .