1

I could view the list views perfectly fine when I 'Login As' the user in desktop version. However, when I use the Salesforce Mobile App, I could not seem to load the list view, it says:

Looks like there's a problem
Can't load the list view

Error loading list view

When I login as a System Admin all of the list views load fine (both Desktop and Mobile)
When I login as this particular user (custom profile) it only loads well in Desktop and NOT in Mobile.

Also noticed, that ONLY, "My Leads" list view renders fine. "Recently Viewed Leads" which I believe is a standard list view did not load well.

Does anyone know how to resolve this please?
Many thanks in advance!

Edit: It seems, it is caused by the Roles. When the user assigned to the most bottom of the Role is is working fine. If the user is assigned a role which is one level higher then this error is showing. Example:
Ceo -> Territory Manager -> Manager -> Sales User
Works for Sales User role but not Manager and the rest of higher level roles.

3
  • Sounds like a case for support to me :(
    – Matt Lacey
    Commented May 2 at 8:49
  • 1
    @MattLacey Thanks alot for your response, I thought the same too and have contacted them, will share the outcome with the community :)
    – prem22
    Commented May 3 at 15:44
  • @prem22 Seem like this is bug with salesforce can you review KI (issues.salesforce.com/issue/a028c00000yEjOjAAK/…) and try workaround mentioned.
    – Vinay
    Commented May 7 at 17:49

1 Answer 1

1

I just had this issue in desktop Salesforce, so posting in case anyone is googling for the same answer - "Can't load the listview." The issue was due to the Profile assigned to the user did not have an assigned Publisher Layout.

Setup > Global Actions > Publisher Layouts > Publisher Layout Assignments > Set the Publisher Layout for {Profile} to "Global Layout" > Save

New contributor
Thomas Overland is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • Yes as @Vinay commented in the original post, this is a bug, Salesforce has scheduled a solution release at the time of writing this reply. Thank you very much!
    – prem22
    Commented yesterday

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .