2

We are trying to integrate from Fusion Middle Ware(FMW) to SFDC sandbox, this is a one way integration from FMW to SFDC custom objects.

Target sandbox is at version 31 both before and after 2014-06-27

2014-06-27 Authentication successful, and all records were successfully integrated and records were inserted till last friday 6/27 when the SOAP Address in Enterprise WSDL was 'soap:address location="https://test.salesforce.com/services/Soap/c/30.0/XXXXX'.

2014-06-30 The SOAP address is changed from 30 to 31 since Monday 6/30 and Enterprise WSDL now shows 'soap:address location='https://test.salesforce.com/services/Soap/c/31.0/XXXXX'. As a result we are not able to insert the records in SFDC sandbox now and getting an error response to FMW:

'General runtime error: Cipher not initialized'

We tried to insert records using v30 API as well as v31 API, but this error still persists.

Kindly let me know if someone can help in resolving this issue.

Appreciate quick response & thanks in advance.

Abhishek

  • Can't you just use the version 30.0 WSDL? – metadaddy Jul 1 '14 at 19:34
  • We have tried with both v30 as well as v31, but still getting the same error. – user10198 Jul 2 '14 at 11:35
  • Sounds like you should open a case with Salesforce support. – metadaddy Jul 2 '14 at 17:45
1

SF asked that the solution not be disclosed as it is part of their security regime to keep our orgs safe from malefactors. Customers with similar issues should contact SF Support

(I feel weird even writing this)

1

We also encountered this error. The solution is to enable "Strong Ciphers" on your Weblogic or Fusion Middle Ware(FMW) box.

The link to instructions on the installation of "Strong Ciphers" are listed here:

WebLogic:

http://docs.oracle.com/cd/E13205_01/wcp/wng10/userguide/installation.html#1053703

Oracle Application servers:

http://docs.oracle.com/cd/E19644-01/817-5447/sgencryp.html#wp15647

After reading these links you must download and install:

Download Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files. The files can be found at the download page for the J2SE used under the heading Other Downloads

The link to this download can be found here:

(Please put HTTP:// in front of these links!)

For Java Version 6:

http:// www.oracle.com/technetwork/java/javase/downloads/jce-6-download-429243.html

For Java Version 7:

http:// www.oracle.com/technetwork/java/javase/downloads/jce-7-download-432124.html

Of course you will need admin access to your Weblogic / Oracle server to perform these steps. This solution solved our issue with

'General runtime error: Cipher not initialized'

0

There would be innumerable number of reasons for Cipher not initialized error but I am sure the above reason is because of SSL certificates and You have seen the above error for good reasons as salesforce.com ensures safety and security.

You will be able to integrate successfully to this instance by deploying latest version of Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files- 6 for JDK1.6 on the SOA server in FMW. Here is a good article for enabling strong ciphers in FMW: http://docs.oracle.com/cd/E19644-01/817-5447/sgencryp.html#wp15647

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.