15

Eclipse - Kepler (3.4), Force.com IDE latest version (a/o 7/1/14) One project worked fine, another project was displaying errors & was unable to be upgraded. I deleted the project and went to create a new one, and am now getting the following error:

Unable to fetch organization details for 'email@domain.com.sandboxname':

Invalid Api version specified on URL

To ignore this error and create an empty Force.com Project without connecting to the server, click Create Offline.

I've tried refreshing my security token, but I'm not seeing any change.

  • Nuke it and begin developing with MavensMate – EricSSH Jul 1 '14 at 15:43
  • 1
    Are you sure that you've specified the environment in the drop down on the "New Force.com Project"? If it's from a Sandbox then you should select Sandbox rather than Production. – Doug B Jul 1 '14 at 15:55
  • I tried MavensMate; it doesn't seem to have the functionality that I've grown used to. – Duncan Stewart Jul 2 '14 at 17:23
  • Thanks Duncan Stewart, it works for me...thanks a lot... – user10220 Jul 2 '14 at 19:55
  • I'm getting this also, SF newb, just created my salesforce.com developer account today. Fresh install of JRE, Eclipse and the IDE from instructions: developer.salesforce.com/page/Force.com_IDE_Installation – mxmissile Jul 2 '14 at 20:58
7

Here is the solution---I have just realized that you might have upgraded the IDE version to 31.0 as your sandbox is on summer release.You are getting the error when you are trying to connect to a sandbox or production org which is on spring release. You can connect to an org with a lower API version but not to connect to a higher version. That is the reason why you get Invalid Api version specified on URL error. So you will have to revert back to IDE version 30.0

  • Was version 30.0 the one that had so much trouble identifying code errors and/or showing all changed files that saved successfully to the server as 'dirty'? – Duncan Stewart Jul 1 '14 at 18:48
  • That issue has been resolved and fixed by SFDC, so it should be fine. If you are not confident enough, install the 29.0 version. – varun guruvugari Jul 1 '14 at 18:52
  • Cool. Please mark this as the answer. – Richard N Jul 1 '14 at 22:48
  • @DuncanStewart: Mark the above as the answer if it works for you as I have seen lot of users face this issue with Data loader, eclipse, ANT. – varun guruvugari Jul 1 '14 at 23:12
  • Unfortunately, neither 29.0, 30.0 or 31 appears to be able to work with what I have; now I guess I need to go to an earlier version of eclipse and try 30 and/or 29 again. – Duncan Stewart Jul 2 '14 at 17:24
3

I have had the same issue Failed to login: UNSUPPORTED_API_VERSION - Invalid Api version specified on URL with my ANT migration tool.

I updated my ant-salesforce.jar file to the latest v30 API version from Salesforce.

The reason why I am asking for your ant-salesforce.jar file is, with the latest release of Salesforce (Summer '14) we are now using the API specified in the package.xml file for the retrieve call. Previously we were using the API specified for the endpoint URL. I will need to use your file to capture the login request and see which API is being used specifically.

"API Version in package.xml Used in retrieve() Calls Starting in API version 31.0, retrieve() calls use the API version that’s specified in package.xml. The API version in package.xml overrides the version that’s specified in the RetrieveRequest parameter. If the version is not specified in package.xml, the version that’s specified in the apiVersion field of the RetrieveRequest parameter is used. This change enables you to retrieve components in any API version by updating the version in your package.xml file. You no longer need to change the endpoint in your API client or download a new version of the Force.com Migration Tool to make a retrieval with a new API version." https://help.salesforce.com/help/pdfs/en/salesforce_summer14_release_notes.pdf - pg 309

0

Are you sure that you've specified the environment in the drop down on the "New Force.com Project"? If it's from a Sandbox then you should select Sandbox rather than Production.

enter image description here

  • Yes - I believe that going back to version 30.0 will do the job, if I can find a link to that version – Duncan Stewart Jul 2 '14 at 17:01
  • In Eclipse we follow the normal Force.com IDE Plugin instructions, except we can choose to not Show only the latest versions of available software. Help | Install New Software... Click Add... button to add a new site. Call it "Force.com IDE (Old)", give it the value of adnsandbox.com/tools/ide/install and click OK. Untick the "Show only the latest versions of available software" Expand the Force.com IDE node and we'll see that there are the previous versions. Also we can directly go to the previous version by using the site URL of adnsandbox.com/tools/ide/previous – varun guruvugari Jul 2 '14 at 20:28
  • Below is an article which was written by me, so let me know if that helps: help.salesforce.com/apex/… – varun guruvugari Jul 2 '14 at 20:30
  • @varunguruvugari can't get older versions to install, getting "Cannot complete the install because one or more required items could not be found. Software being installed: Force.com IDE 27.0.0.201302151147 (com.salesforce.ide.feature.feature.group 27.0.0.201302151147) Missing requirement: Force.com IDE 27.0.0.201302151147 (com.salesforce.ide.feature.feature.group 27.0.0.201302151147) requires 'org.eclipse.update.ui 0.0.0' but it could not be found" – mxmissile Jul 3 '14 at 13:58

protected by Community Jul 2 '14 at 23:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.