We are creating a new API v59.0 record-triggered flow (create or update) on account object (for person account records in specific) which has a custom restricted picklist field. We are referencing the field in formula used in as the entry condition. Criteria is simple:

TEXT({!$Record.Picklist_Field__c}) <> 'specific value'

execute the flow

While debugging the flow, if the picklist is set to one of the available values, it works as expected, but when the picklist value is kept blank, we get the following gack error (kind of https://developer.salesforce.com/blogs/engineering/2015/02/gack): enter image description here

Error ID: 743738450-253589 (1192326156)

Strange thing is that the flow works as expected when activated and triggered real-time even with the picklist field being blank. We are sticking to formula as we have some additional criteria to evaluate not part of the triggering record. The error is thrown when debugged as both syst admin and as normal end user, so doesn't seem to be an issue with FLS. The error is not thrown when we set 'Skip start condition requirements' while debug. There's also no issue when using the 'All Conditions Are Met (AND)' option as the entry condition with just the following:

Picklist_Field__c DOES NOT EQUAL Specific_Value

Capturing debug logs doesn't help as it won't occur in real-time.

Does anyone know if it's a known issue when the formula references a null picklist field as part of the entry condition in record-triggered flow? Is it possible to debug and find more details on cause of the error? Even though the automation works in real-time, we are bit hesitant to proceed. Appreciate any inputs!

  • try NOT(ISPICKVAL({!Record.Picklist_Field__c},'specificValue'))
    – cropredy
    Commented Mar 25 at 18:44
  • @cropredy, thanks for the suggestion but have already tried and the same error. Just to add that the flow runs for both create or update and throws errors in both cases if the value is null
    – Borz998
    Commented Mar 25 at 20:16
  • and we are dealing with person account records in specific
    – Borz998
    Commented Mar 25 at 20:29

1 Answer 1


This seem to be a bug with salesforce. Kindly review KI details and try below workaround.

  • Keep this entry criteria formula into a formula resource and use a decision element as the first element in the flow to determine whether the flow should continue executing or not.

    Note: Add a simple condition in the entry criteria if the Flow has an Asynchronous path to avoid further errors.

  • 1
    Thanks @vinay for the reference!
    – Borz998
    Commented Apr 1 at 1:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .