0

Getting error while setting up salesforce lwc local development:

PS C:\Users\hp\Desktop\SajjanTestProject> sfdx plugins:install @salesforce/lwc-dev-server Polling for new version(s) to become available on npm... done Successfully validated digital signature for @salesforce/lwc-dev-server. Finished digital signature check. Installing plugin @salesforce/lwc-dev-server@latest... failed » Warning: @salesforce/lwc-dev-server > @salesforce/[email protected]: Package no longer supported. Contact
» Support at https://www.npmjs.com/support for more info. Error: C:\Users\hp\AppData\Local\sf\client\2.30.8-d9ea14b\node_modules\yarn\bin\yarn.js add @salesforce/lwc-dev-server@latest --non-interactive --mutex=file:C:\Users\hp\AppData\Local\sf\yarn.lock
--preferred-cache-folder=C:\Users\hp\AppData\Local\sf\yarn --check-files exited with code 1

1 Answer 1

0

I had exactly this issue and

npm install -g node-gyp

fixed it for me. Apparantly this doesn't work for everyone. For a similar problem see here.

Why this is undocumented or unnecessary for some (such dependencies should be installed automatically), is beyond my knowledge.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .