0

When attempting to modify Language and TimeZone settings through Personal Settings, I encounter the 'Insufficient Privileges' error, even though I am logged in as a user with the System Administrator profile

enter image description here

I managed to resolve this issue by activating the 'Enable the Improved Setup User Interface' user setting, as illustrated in the images below:

enter image description here

Now, I am in search of a method to enable this setting in the project-scratch-def.json file for a scratch org, eliminating the need for manual adjustments every time a new scratch org is created.

Despite thorough examination of the settings, I have been unable to identify a corresponding field for configuring this option (docs: https://developer.salesforce.com/docs/atlas.en-us.248.0.api_meta.meta/api_meta/meta_userinterfacesettings.htm)

0

You must log in to answer this question.