0

When I run sf project retrieve start on a production Org, it says:

Error (1): This command can only be used on orgs that have source tracking enabled, such as sandboxes and scratch orgs

Is there a way to retrieve all project files locally from a production environment? Is this possible using the Salesforce CLI?

On my sandbox this solve the issue, but I would like to do the same on production if possible in any way.

5
  • 1
    Not something I've tried. Depending how the updated CLI behaves, you might be able to use the deprecated (legacy) sfdx force:source:retrieve command. This didn't require source tracking. Interestingly, that documentation suggests sf project retrieve start should automatically work against an org without source tracking enabled...
    – Phil W
    Commented Jan 25 at 17:36
  • Always helpful to mention what the version is for things that you're using (and always a first step to check to see if there are updates).
    – Derek F
    Commented Jan 25 at 18:24
  • @PhilW your solution seems to work. Is there a way to keep doing this in future versions as this method is deprectated?
    – Z0q
    Commented Jan 27 at 11:41
  • 1
    Honestly not sure, but the point is it should be able to work with the new command. Perhaps you should consider raising a bug in the CLI bug tracker?
    – Phil W
    Commented Jan 27 at 11:48
  • 1
    @PhilW Posted an issue on Github: github.com/forcedotcom/cli/issues/2693
    – Z0q
    Commented Feb 6 at 9:56

1 Answer 1

0

As answered on the GitHub issue I posted for this

sf project retrieve start (with no flags) will try to retrieve the changes, and requires source tracking.

Possible options

sf project retrieve start --source-dir [wherever your project files are

or sf project retrieve start --metadata x to get all the metadata of one or more types if you know what you want.

Source

https://github.com/forcedotcom/cli/issues/2693#issuecomment-1929770246

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .