2

I've created a new experience from scratch (the LWR Build Your Own template), created a component that implements a screen flow, and added to the home page of the newly created site.

The whole thing works if I'm logged in:

logged in/experience builder preview result

But doesn't when I open on a private window:

private window result

Already checked that:

  1. The site's guest user profile's "Flow Access" grants access to the screen flow.
  2. The Digital Experience is Activated instead of in Preview.
  3. The site's "Public Access" setting "Guest users can see and interact with the site without logging in" is checked.
  4. The page's "Page Access" is set to "public".
  5. The Default Experience on the profile is set to the Experience Site's.
  6. The flow's "How to Run the Flow" setting is set to "System Context Without Sharing".

Is there something I'm missing here? How can it be so difficult to publish a simple page with a screen flow for public access?

0

1 Answer 1

3

I think this is your issue: LWC Digital Experience Unauthorized Access

ok, I figured out my issue; thanks to rene winkelmeyer's "How to build LWR sites with Experience Cloud", specifically episode 9; my missing item was: setup> all sites> select this site> Administration > Preferences > Allow guest users to access public API

It is also described here in the docs:

 For LWR sites, return to Experience Builder and click Workspaces | Administration.
 Click Preferences and select Allow guest users to access public APIs.

I hit the same issue as you, but once I did this, my simple POC flow appeared

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .