1

When I perform the "SFDX: Authorize an Org" step of the project in VS Code, I get the error "Ignoring extra certs from null, load failed: error:80000002:system library::No such file or directory". To solve this error, I checked whether "sf-x64" was installed. If it wasn't installed, I reinstalled it but the problem persisted. Then I realized that OpenSSL was not installed, so I installed it and repeated the process. I restarted the computer after each step, thus taking precautions to avoid syncing issues. However, the problem is still not resolved.

I wrote the full error below=>

"Starting SFDX: Authorize an Org

14:21:00.710 sfdx org:login:web --alias vscodeOrg --instance-url https://login.salesforce.com --set-default

Warning: Ignoring extra certs from null, load failed: error:80000002:system library::No such file or directory

You acknowledge and agree that the CLI tool may collect usage information, user environment, and crash reports for the purposes of providing services or functions that are relevant to use of the CLI tool and product improvements.

Successfully authorized [email protected] with org ID 00DWT000000IXjt2AG

14:21:26.718 sfdx org:login:web --alias vscodeOrg --instance-url https://login.salesforce.com --set-default

ended with exit code 0"

2
  • The second part of the citation seems to state that you were successful authorizing at least one org - were you?! Does this only happen in this particular project, or does this happen with all your projects? I assume you are on the latest version of VSCode (compare this)? Commented Dec 27, 2023 at 9:58
  • "I checked the Visual Studio Code for updates, and it's currently up to date. Yes, it asks me to go to the website and log in, and I do that. However, the necessary authorization is not happening. The OUTPUT shows me this output, and I can see the error there. I've updated Salesforce and reinstalled OpenSSL, but it's still not working. Thinking there might be an issue with my PC, I tried it on my old PC, but it didn't work there either." Commented Dec 27, 2023 at 11:21

1 Answer 1

0

After trying many ways, I've solved the issue! The last method I did: First, I added the Salesforce CLI to the Windows %PATH, and then I also added it to the path of the Salesforce extension in Visual Studio Code. However, it still couldn't find the certificates. Later on, I downloaded them through the terminal command, not from Salesforce's official website (this might be a different approach due to setup). After adding them to %PATH again and integrating them into the Visual Studio Code extension, it worked! I'll post a proper update soon.

2
  • I am also receiving this error, but couldn't quite follow your answer. Can you please post a more detailed step-by-step of what you did? Thank you.
    – bpilling
    Commented Jan 26 at 0:26
  • Hi, First of all, enter VSC code, type salesforce in the settings, enter the 'salesforce Core Configuration' section and check whether the NODE_EXTRA_CA_CERTS section on the right is filled. If it is empty, open the script, find where it is installed with 'where sfdx', you need to write the NODE_EXTRA_CA_CERTS path into it correctly. If it still does not work or if the commands do not appear, sfdx has not been installed and if it is VSC code, the correct plug-ins have not been installed. It includes the ones before the badge you are currently stuck with from the trailhead. Commented Mar 3 at 5:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .