0

Error:

Error when invoking /support/conversations/0X9060000004H25/invocations/0SC06000000Gx9bGAC: [{"actionName":"setup_bot__IntroBotPreChatContext","errors":[{"statusCode":"UNKNOWN_EXCEPTION","message":"An error occurred when trying to start a flow interview.",

Issue is reproducible from Bot Preview.

Also Flow Run direct run generates a gack id.

Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details. Error ID: 695596427-41500 (-504978616)

1 Answer 1

0

In general, this article https://help.salesforce.com/s/articleView?id=000396637&type=1 suggests that some permissions are missing.

However, I have changed the running user to admin and the issue is still present.

I have opened a SF Support case for this one.


Update: Salesforce support claims that this error happens because Messaging feature is not available in the current trial org.


This article https://help.salesforce.com/s/articleView?id=sf.bots_service_create_template.htm&type=5

says that Messaging license is required for Intro template.

On the contrary, first line of this documentation claims that

This template is designed for use only with the Chat channel.

which means it should not depend on messaging feature at all. However, the third line of this documentation article says

To deploy a bot using the template, your org must have Chat and Messaging enabled.

Contrary, at the end of this article you can find a clue that Messaging channel is actually supported

To link this bot to a Messaging Channel, skip this step and add the connection on the Bot Overview page.

This doesn't make sense to have this intro template available for an org where messaging license is not enabled.

Salesforce Support specialists suggest that since Intro Template is designed for both Sales Cloud and Service Cloud and Sales Cloud chat bot implementation requires Messaging

https://help.salesforce.com/s/articleView?id=sf.sales_core_digital_engagment.htm&type=5

then it should require messaging.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .