0

There is a custom object called Technical Assistance(Technical_Assistance__c) and Chatter has been placed on the Lightning Record Page which is the default record page by virtue of being the Org Default.

The problem is that although the Chatter component displays it is not possible to post anything in Chatter.

"Feed Item" in Setup was used to turn on Chatter for this Custom Object. After which it became possible to add the Chatter components to the Page Layout.

Chatter is enabled in the Org via Chatter Settings in Setup.

Chatter works fine on the Lead object.

To further test the problem a fresh sandbox was created. With no changes made to the custom object or it's lightning record page in the Sandbox it was found that Chatter was working perfectly.

I have two questions

  1. Why doesn't chatter work in production on the custom object
  2. Why did it work properly in the Sandbox despite making no changes

Chatter component not working Notice in the above screenshot nowhere to add a Post. The component is "Chatter" on the Lightning Record Page.

1 Answer 1

0

Whilst typing up this question I discovered the answer. On the custom object I had to edit the Classic page layout, Override the "Salesforce Mobile and Lightning Experience Actions" and add in "Post" from "Mobile & Lightning Actions".

It then worked perfectly.

However I still have no idea why it worked fine in the Sandbox despite nil configuration changes but I hope this helps others who are stuck in their Production instance.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .