I have a recently refreshed sandbox built against our production org. I need to authorize my SFDX environment so I can push the source code to it. I've executed these shell commands:

% sf org login web --alias MySandbox --instance-url https://ourdomain--mysandbox.sandbox.my.salesforce.com
Successfully authorized [email protected] with org ID 000000000000000000

% sf org display --target-org MySandbox --verbose

=== Org Description

 KEY              VALUE                                                                                                                                                          
 ──────────────── ────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────── 
 Access Token     0000...                                               
 Alias            MySandbox                                                                                                                                        
 Api Version      59.0                                                                                                                                                           
 Client Id        PlatformCLI                                                                                                                                                    
 Connected Status NamedOrgNotFoundError                                                                                                                                          
 Id               000000000000000000                                                                                                                                             
 Instance Url     https://ourdomain--mysandbox.sandbox.my.salesforce.com                                                                                                      
 Sfdx Auth Url    force://PlatformCLI::[email protected] 
 Username         [email protected]      

So I'm being told that the sandbox is successfully being authorized, but then I'm told that the connected status is "NamedOrgNotFoundError." How do I fix this?

A few more potential clues:

  • I thought of just starting over and executing sf org delete sandbox --target-org MySandbox, but this results in Error (1): The target org, ourdomain.com.mysandbox, is not a sandbox. But sf org list shows that org has no expiration, so it's not a scratch either (?). (Note that MySandbox is my current default org as I'm doing this.)
  • Since it's being reported that it's not a sandbox, I thought I'd try sf org delete scratch --target-org MySandbox, but that errors with Error (1): No authorization information found for MySandbox.

1 Answer 1


As with this question, the answer was a circular alias reference. I had tried to sf alias unset for my MySandbox alias, but there was also an alias from the user name to the MySandbox alias, and unsetting this fixed the problem (or more accurately, sf alias username= worked).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .