0

Trying to integrate react-native 0.68 with "react-native-marketingcloudsdk": "^8.0.0"

The app crashed with the below error. Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: 'Cannot create an NSPersistentStoreCoordinator with a nil model'

In the documentation, it's showing as common exceptions. Common Exceptions When latest MarketingCloudSDK.bundle not added in the application.

But I don't know how to add the bundle.

https://salesforce-marketingcloud.github.io/MarketingCloudSDK-iOS/trouble/trouble-marketingCloudSDK-bundle-exception.html

enter image description here

2
  • 1
    Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Nov 20, 2023 at 9:40
  • @Community I have edited the question
    – katik S
    Nov 20, 2023 at 9:51

1 Answer 1

1

Fixed it by adding MarketingCloudSDK.bundle to Build Phases -> Copy Bundle Resources from the pod.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .