yesterday I tried to refresh sandbox in orgs And now It indicates that ready to activate the sandbox enter image description here

but when I tried to use sf data update record with below full command

sf data update record --json --use-tooling-api --target-org $targetOrgAlias \
      --sobject SandboxInfo --record-id $sandboxInfoId \
      --values "RefreshAction=ACTIVATE" --values "LicenseType=$licenseType"

It prompts below error

The sandbox you tried to refresh or delete has a current status of ACTIVATION_PENDING_CONFIRM. Wait until its status is Finished, and then try again.

enter image description here so Im wondering which field I should update to activate sandbox?

1 Answer 1


I think I found issue by myself, It should updateRefreshAction=ACTIVATE in sobjectSandboxProcess instead

sf data update record --json --use-tooling-api --target-org $targetOrgAlias \
      --sobject SandboxProcess --record-id $sandboxProgressId \
      --values "RefreshAction=ACTIVATE"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .