0

I have a custom app that I have developed and provisioned to an Account Record page (as well as other Record pages) in a custom tab (named "S" in the picture below). The small component window on the right side of the page stays in the correct position for all tabs except the custom tab.

Correct Layout

I am seeing an issue where opening that tab will cause the component window on the right side of the page to move from the row that it is in to below the larger component window that is in the same row (see below). When I click on one of the other tabs, the behavior does not resolve and it takes a full page refresh to get the layout back to its rightfull place.

enter image description here

I thought this might be some kind of an html overrun from its container, but I see this even after ALL elements are removed from the package. Even with no content in the component, the problem still shows itself by "pushing" the smaller window to the next row. I am completely stumped since I have removed all HTML elements and styling from the package but still see the behavior. This seems like a recent problem since I don't recall seeing it before recently. Has anyone seen/resolved a similar problem?

3
  • I believe this has something to do with the overall page layout within the custom tab. I would click the gear icon top right and select edit page and move things around that way to see if this resolves your issue.
    – twolfe
    Nov 10, 2023 at 19:16
  • This is really a comment, not an answer. With a bit more rep, you will be able to post comments.
    – identigral
    Nov 10, 2023 at 19:25
  • I can work around the issue by changing to the "Header and One Region" template so the record page tabs operate at full page width but some customers operate with a Sidebar (Either Left or Right) and I cannot avoid the issue if that is the template that they use.
    – bswartz
    Nov 10, 2023 at 20:26

0

You must log in to answer this question.