1

For several years I have been using the SF CLI retrieve commands in VS Code to retrieve data from my Partial Copy Sandboxes to my local git repo.
About a month ago I moved from using the force:source:retrieve commands to the project retrieve start commands. Over the last few weeks I had seen occasional delays when trying to retrieve a single component. Usually by the time I would start to troubleshoot the delay would resolve and not return for the rest of the day.

Since the beginning of this week it is been taking over 5 minutes to retrieve a single component - the request just hangs on Preparing retrieve request... ⣾ Pending

I have tried the following and received the same results...

  1. Confirmed Perform Synchronous Compile on Deploy is disabled under Apex settings in my Partial SBX Orgs
  2. Disabled Enable Source Tracking For Deploy And Retrieve in SF Core Cofig in VS Code
  3. Downgraded to an older version of CLI
  4. Deleted VS Code sfdx.log file.
  5. Used the legacy force:source:retrieve commands
  6. Retrive via manifest.xml

This is happening across multiple Sandbox Orgs and impacting me and my colleague. Any help in troubleshooting would be greatly appreciated

Configuration

  • VS Code 1.84.2
  • M1 MacBook Pro Ventura - 13.6 (22G120)

1 Answer 1

0

UPDATE Rolling back Salesforce Extension Pack to v57.10.2 as described here worked for me.

Experiencing the same problem retrieving metadata. Did a complete uninstall, shut the machine down, reinstall and same issues. Seems like it will work somewhat decent on the very first retrieve after a shut down but too slow after that. Not annoying slow, productivity killer slow like I need to find a new IDE . Deploy is still always snappy.

Mac Silicon Ventura 13.5 VSCode 1.84.2 @salesforce/cli/2.17.14 darwin-arm64 node-v20.9.0

1
  • I saw that post and tried downgrading. At the time this did not help. I have since re-upgraded. Over the last few weeks I have not experienced delays. Commented Nov 27, 2023 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .