0

No sure if it's local config or OS upgrade but my sf cli commands have been broken especially the packaging commands.

When I run below command I get an error related to JIT plugin (I am assuming JIT stands for Just In Time)

Command:

sf package installed list

Error:

(node:9088) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
(Use `node --trace-deprecation ...` to show where the warning was created)
Installing plugin [email protected]... ⣾
warning Skipping preferred cache folder "/Users/<myusername>/Library/Caches/sf/yarn" because it is not writable.
warning Selected the next writable cache folder in the list, will be "/Users/<myusername>/Library/Caches/Yarn".
(node:9089) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
Installing plugin [email protected]... ⣽ [1/4] Resolving packages...
Installing plugin [email protected]... failed
    JitPluginInstallError: Could not install @salesforce/plugin-packaging
    Code: JitPluginInstallError

Upon receiving this error, I removed all sf cli and sfdx cli from my machine, restarted it and re-installed sf cli. I got the same errors. I tried installing the packaging plug-in separately using below command but to no avail.

Command:

sf plugins install @salesforce/plugin-packaging

Error:

Confirm Execution: This Sudo Command requires admin rights. Are you sure you wish to proceed? Yes/No: Yes

(node:9201) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
(Use `node --trace-deprecation ...` to show where the warning was created)
Polling for new version(s) to become available on npm... done
Successfully validated digital signature for @salesforce/plugin-packaging.
Finished digital signature check.
Installing plugin packaging@latest... ⣻
(node:9217) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
Installing plugin packaging@latest... ⢿ [1/4] Resolving packages...
Installing plugin packaging@latest... failed
    Error: /usr/local/lib/node_modules/@salesforce/cli/node_modules/yarn/bin/yarn.js add @salesforce/plugin-packaging@latest --non-interactive
    --mutex=file:/Users/<myusername>/.local/share/sf/yarn.lock --preferred-cache-folder=/Users/<myusername>/Library/Caches/sf/yarn --check-files exited with code 1

I tried all of this on and off of VPN as well as disabling the anti-virus but I kept getting the same error.

1

1 Answer 1

0

Changed the .npm-global paths and the commands have started working for me.

Reference: https://stackoverflow.com/questions/48910876/error-eacces-permission-denied-access-usr-local-lib-node-modules

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .