4

Today I went nearly crazy while working on an Aura component. I'm saving my work but the UI does not update. Damn! Waiting a while (about 10 minutes) my changes are finally showing up.

This is unacceptable for development!

For sure I have disabled "Enable secure and persistent browser caching to improve performance" - for good.

This must be related to the Winter 24 Release, because I know that a few days ago I was perfectly able to save my updates and get the result immediately rendered on the UI.

How can I develop and debug components like before Winter 24 Release?

Still Open

In the meantime I found a viable workaround (see my answer below).

But I'm still looking for even better ways to deal with this situation. So every feedback and any idea is highly appreciated! Thanks in advance.

1 Answer 1

4

It took me like forever but I found out that this as a new "feature":

Changes to Aura components and Lightning web components (LWC) take up to 10 minutes to reflect in the UI

Publish Date: Oct 2, 2023

Description After Lightning Experience has been bootstrapped, the browser dynamically requests the latest version of the component definitions. The server responds with a 302 redirect to the specific version of the component. In Winter '24, code changes in Aura and LWC components can take up to 10 minutes to reflect in the UI due to HTTP caching of Aura and LWC component requests for the latest version.

Unbelievable...

Salesforce recommends:

Resolution

To see component updates without a delay during debugging or testing, enable Debug Mode for Lightning Components or hard refresh the browser to clear the browser cache.

Both resolutions are absolutely inacceptable for me:

  • Developer Mode adds extreme slow down (much much more than the cache affects anything)
  • Developer Mode brings up lots of nasty popups I need to click away
  • always manually clear the cache costs too many clicks and is annoying

IMO such developer unfriendly "features" should come with an OFF-switch. Such changes should be better announced and better communicated to developers.

After wasting some time I've found a workaround:

There is a Chrome Extension called Classic Cache Killer. This Extension can be enabled with one click. Then each reload brings an immediate update to the UI. When done developing I can disable the Extension with one click.

enter image description here

Acceptable for my workflow.

A performance degradation is likely, but it is much less than using Debug Mode. The result feels very similar to the performance I was used to get before Winter 24 Release.

1
  • And the delay still happens even if you disable the session cache? If so, that is annoying! Oct 12, 2023 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .