0

Hi have an issue when deploying a flow from a sandbox to another :

An unexpected error occurred. Please include this ErrorId if you contact support: 1884642260-375043 (1535387224)

Could you help identify what is wrong ?

Thank you

16
  • 1
    Nope, most of us here can't do a thing with that error. What you have there is called a GACK. The first two numbers (separated by a hyphen) are the "event id", and the second number (in the parens) is a stack trace identifier. Both of those are really only relevant to Salesforce's official customer support (99.9% of us here are customers of Salesforce, like yourself. Not Salesforce employees). If you're lucky, you may be able to find more info by searching for the number in the parentheses. Beyond that, this is something to open a support ticket with Salesforce for.
    – Derek F
    Sep 25, 2023 at 11:10
  • 4
    What you are seeing is a GACK . From Salesforce backend logs for the stacktrace Id 1535387224 I see message as Metadata gack caused by: NullPointerException java.lang.NullPointerException on id 3011w000000jx4Q Sep 25, 2023 at 11:11
  • 2
    Does this answer your question? Internal Server Error - What's in a GACK?
    – identigral
    Sep 25, 2023 at 15:20
  • 1
    if you can, either a) rebuild the flow manually in the target sandbox, piece-by-piece; this may help identify the issue (as there is some environment difference). b) verify both sandboxes are on the same SFDC version; or c) simplifiy the flow in the source sandbox and deploy, then add back pieces until you get a failure. Your issue is on an object whose key prefix is 301 which is InteractionDefinitionVersion
    – cropredy
    Sep 25, 2023 at 17:00
  • 1
    I found the issue by deconstructing the flow piece by piece in the source ord and testing the deployment for every piece removed from the flow. A field was missing in my change set. Thank you guys for the help
    – Clem Chvlr
    Sep 25, 2023 at 17:13

1 Answer 1

1

I found the issue by deconstructing the flow piece by piece in the source org and testing the deployment for every piece removed from the flow. A field was missing in my change set. The answer from Swetha helped me a lot too. Thanks

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .