I tried all three suggestions from another question asked in this community "Data loader CSV Error: Can't read from CSV file" and none of those answers solved my problem.

  • I just loaded Data Loader v59.00 yesterday. Is there something specific about this new version that is causing a problem?

  • When I looked back at the the version (v57.0.1) I had on my old computer, there was no line for anything about the process.mappingFile=. Is it possible that it is not needed and that is just "confusing" DataLoader?

  • We are having this issue in our company as well. Has anyone know what is causing this issue please? Thanks, Joana Oct 10, 2023 at 14:44
  • For anyone running into the issue, I recommend downloading v58 here. This is most likely a bug that needs to be fixed by Salesforce, so the prior version should suffice until it's fixed. The exact same file worked fine for me on v58.
    – zainogj
    Oct 13, 2023 at 15:38

5 Answers 5


I fixed this problem by:

In the Dataloader 59.0 Settings:

in the "Other Delimiters:" box, remove the "-"

Click OK.

  • Downloaded DL v59.0.0 and hit this exact error. CodeBabe solution worked.
    – Dave
    Nov 1, 2023 at 15:29

v59 is very picky regarding the CSV format. My Excel exports CSV's WITHOUT quotes and DL v59 wants CSV WITH quotes. I just used "Ron's CSV Editor" to "fix" a CSV file that was constantly giving the error and it went right thru this time.


I ran into an issue with a file as well and reached out to support. They referred me to this help article Error 'CSV Error: Invalid CSV file format' with unicode CSV files, but that didn't fix the issue. I ended up using an older version of Dataloader and it worked fine.


I was running into the same problem. I deleted the process.mappingFile line from the config file and it worked. I suggest cutting the line out and paste it elsewhere just in case.

I am currently using v58.0.


I downloaded version 60 and this solved the issue. PIA!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .