0

I am experiencing an issue with the Apex Language Server not running in VS Code. I have looked for solutions to this issue. The only thing I found recommended trying to set the Java path in the Salesforce VS Code extension settings. That was already set. Everything has been working for a long time until just recently. I updated the extension pack as well but that didn't help.

I'm not sure where else to look.

enter image description here

1 Answer 1

1

I solved a similar problem. Apex Language Server in VSCode failed to launch because it is now compiled requiring a later version of Java. Check the Apex Language Server panel to confirm the errors.

My error was: ApexLanguageServerLauncher has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Based on this, class file 55.0 means I would need to have Java 11 and I only had Java 8 on my Mac.

Solution:

Go to Adoptium.net as recommended here and download the JDK. I got MacOs x64 JDK 17 Temurin which is the latest LTS version. Download it, check the checksum and install it.

In VSCode:

Preferences > Search for java, then set
Salesforcedx-vscode-apex › Java: Home
to:
/Library/Java/JavaVirtualMachines/temurin-17.jdk/Contents/Home/
1
  • Yeah, I discovered the same thing. I forgot to come back and update my question with an answer. It used to work for me so I guess the Salesforce extension updated to use a new version of Java.
    – James
    Sep 21, 2023 at 18:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .