0

I need to downgrade to this version(7.181.1) as the whole team uses it for a scratch org script. I've tried using the most previous one I can find 7.199.2 and the most recent 7.209.6.

Either one will cause me to fail the metadata deployment to the new scratch org on the line:

<searchResultsAdditionalFields xsi:nil="true"/>

With the Error:

Error parsing file: Attribute name "xsi:nil" associated with an element type "searchResultsAdditionalFields" must be followed by the ' = ' character.

I've tried just about everything in this documentation: Install Salesforce CLI

If anyone could tell me how to revert to a deprecated version or belive I am missing something else, I'm all ears.

2
  • Are you using the binary or npm package?
    – sfdcfox
    Sep 6, 2023 at 1:54
  • I tried both. I wasnt able to revert any farther than 7.199.2.
    – JEbert
    Sep 6, 2023 at 21:17

1 Answer 1

0

If anyone runs into a similar issue with <searchResultsAdditionalFields xsi:nil="true"/> its an old bug. https://developer.salesforce.com/forums/?id=9062I000000R0raQAC

This tag gets created in the metadata when a search layout field was added to an object that had its tab removed. I believe it try's to label the field as null. Either way the cli version I was using caught the issue where as the older versions my colleagues are using did not. The fix was just to remove all the data inside the <searchLayouts> section since they are no longer being used.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .