1

I'm encountering an error with a specific route in my ExperienceBundle. I'm relatively new to working with ExperienceBundle, and I'm seeking assistance to troubleshoot this issue. The routeType and viewType are already correctly matched, but I'm still facing errors. Could someone provide guidance on where to begin troubleshooting this problem? Your help would be greatly appreciated.

the routeType and viewType is already match

Metadata Type API Name Problem Type Problem
ExperienceBundle Homie_NAME1 Error There was an issue with the property routeType in Homie_NAME1/routes/pipelineInspection.json with component ID: c7263124-7bc4-4147-a39a-25fe7e305b98. Update your file and try again.
{
  "activeViewId" : "fed23e18-b57a-4883-a61f-3acf93cb744d",
  "appPageId" : "b216e8cc-cfe1-40e0-81be-8ce9331ce2f7",
  "configurationTags" : [ ],
  "id" : "c7263124-7bc4-4147-a39a-25fe7e305b98",
  "label" : "Pipeline Inspection",
  "routeType" : "pipeline-inspection",
  "type" : "route",
  "urlPrefix" : "pipeline-inspection"
}

1 Answer 1

0

I was having a similar issue. I found there was also a view that needed to deploy as well.

I used a sandbox to retrieve the metadata for the views and routes. Below is a copy of the View for pipeline-inspection.

After adding the view into my deployment package (via Gearset), the deployments started succeeding again.

{
  "appPageId" : "xxxx",
  "componentName" : "siteforce:sldsOneColLayout",
  "dataProviders" : [ ],
  "id" : "xxxx",
  "label" : "Pipeline Inspection",
  "regions" : [ {
    "id" : "xxxx",
    "regionName" : "header",
    "type" : "region"
  }, {
    "id" : "xxxx",
    "regionName" : "content",
    "type" : "region"
  }, {
    "id" : "xxxx",
    "regionName" : "footer",
    "type" : "region"
  } ],
  "themeLayoutType" : "Inner",
  "type" : "view",
  "viewType" : "pipeline-inspection"
}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .