0

enter image description hereI have a requirement to map the Status field on a Parent Campaign to the same field located on the Child Campaign. The two fields should always be in sync.

I created a flow to with a get records element but receive this error: This error occurred when the flow tried to look up records: ParentId FROM Campaign WHERE ((ParentId = '$Record.Id')) ORDER ^ ERROR at Row:1:Column:57 invalid ID field: $Record.Id. enter image description here

When debugging this, everything seems to point to a missing ID, but the the ID I am attempting to fetch is that of the child record so not understand why this would not show. I don't see a way to extract the code from the flow to post here but open to suggestions.

5
  • 1
    Maybe paste a screenshot of get records element here so we can see it.
    – Nick C
    Aug 23, 2023 at 1:34
  • I did modify the flow a bit and the error no longer occurs. In fact the flow runs successfully except it doesn't update the child record like it is suppose to.
    – Ron
    Aug 23, 2023 at 2:33
  • your screenshot says you're getting all campaigns with the same Id as the record. Don't you want all the children?
    – Nick C
    Aug 23, 2023 at 2:57
  • Yes, I should be getting the Id of the child records. However, the reference to the child record doesn't seem to be available when building the flow. I initially used ParentId equals and for the value I had $Record.Id. This is what was throwing the initial error. Somehow I am not referncing the correct Id's. The child campaign is of different record type so don't know if that matters.
    – Ron
    Aug 23, 2023 at 3:23
  • 1
    You need to edit your post to clarify the details. The Get Child Campaigns is definitely wrong since the left-side Field should be ParentId, not Id. The initial error was probably because you have the wrong format, it should be {!$Record.Id}. Aug 24, 2023 at 14:37

1 Answer 1

0

I solved this. Was using the wrong element to make the updates. Used the Update Child Records instead of Update Records. This work exactly as required. The original error was because of not referencing the ParentId for the Campaign where I was referencing just the ID.All solved now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .