1

Objective: I need Salesforce App to have exact same layout which I see in the edit mode of flexipage with form factor of mobile.

Settings Done:

  1. Created a new flexipage, by not importing fields from any layout rather adding the fields one by one directly in the flexipage.
  2. Enabled these flexipages for both Mobile and Desktop form factor at Org Default, App Default, and App, Recordtype and Profile.
  3. There is no custom LWC, VF page or anything on this flexipage, only custom and Standard fields and related list tabs.
  4. The Lightning App also has supported form factor of Desktop and Mobile with Console Navigation.
  5. I'm trying to use this Salesforce app only for internal users (and for testing I tried even with the System Administrator but same result).
  6. Setting the Mobile app for the first time in this org (Sandbox or Production).
  7. Tried Following Videos here although I'm not finding any settings for 'New Mobile App for Quick Start' or for that matter any 'Salesforce' mobile app settings for assigning any flexipages or any settings like that.
  8. Verified all the Settings in Setup --> Apps --> Mobile Apps --> Salesforce.
  9. Tried both ios and Android phones. Cleared cache multiple times in both the phones (both browser and in app cache).
  10. Although the page layout is not directly linked with the flexipage still made the pagelyout also in the correct manner. I tried with the basic objects such as Account and Contacts and the result is same.
  11. The app I'm using is the latest 'Salesforce' app and has been installed with all the updates (if any).
  12. Nothing is set at 'Set Component Visibility' in terms of Device-->Form Factor.

Problem: Not able to see the layouts as is in 'Salesforce' Mobile App... Some related lists, some tabs and most of the custom/standard fields are not visible. Not sure if some more setting is required apart from the above ones. Please help. Thanks.

1
  • Anyone any idea?
    – user43598
    Aug 22, 2023 at 8:09

1 Answer 1

2

If it helps anyone in the future...

Below things helped me...

  1. Setup --> 'Salesforce Mobile App' --> (A Beta feature) 'Dynamic Forms on Mobile (Beta)' needs to be enabled.
  2. Related List: 'Dynamic Related List Single' is not supported on mobile form factor as of now, so do not upgrade the 'Related List Single' if there is no specific requirement of the Dynamic version. And like my case, if update is beneficial for other requirements then create two related lists, one with each type, and then create filter on the form factor.
  3. Fields: Section inside the section was somehow not visible in the Mobile app... So I had to create a separate tab (with visibility filter of only mobile) where I removed less wanted section.
1
  • Great answer! Thanks a lot!
    – prem22
    Apr 16 at 7:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .