1

I do apologize if this has already been asked (recently); I did search and could not find anything specifically dealing with "How to" installations of WorkBench.

A number of weeks ago in July 2023, workbench.developerforce.com was down. It was suggested to try hosting it locally. So, I downloaded the code, and followed the somewhat cryptic instructions to get it installed. However, after a few days of trying this, and trying that, I gave up.

Has anyone RECENTLY tried to download and install the Force Workbench code into a Ubuntu Linux Distro?? I'm not a Linux expert, but with 30 years IT experience, can follow directions pretty well.

Some of the conflicts I was running into, was after installing Ubuntu and updating all the latest security updates (apt update, apt upgrade), I could not find the magic combination of packages ( Apache, MySQL, Php) that allowed everything to run, without throwing an error that there was a conflict.

I have reviewed the installation wiki, and it does not speak of any of the version conflicts that I ran into.

If someone knows the magic steps ( in more detail ) to get this installed (start to finish), please let me know how and/or update the Wiki so that others don't run into this same problem that I did.

Thank you. And much appreciated.

3
  • Have you considered the Salesforce Inspector and/or postman chrome extensions? Not the same as Workbench, and it does depend what you are doing, but may be useful.
    – Phil W
    Aug 11, 2023 at 21:40
  • I'm running an older copy on heroku, but I'll try and spin up a Ubuntu box and see what happens.
    – sfdcfox
    Aug 11, 2023 at 22:39
  • 1
    @PhilW - just looked at SF inspector... interesting tool, but not what I need workbench for. Also have used postman, great tool too. But I like workbench, because there's pretty much everything you need, in 1 tool. I don't have to go here for this, or there for that. And the bulk update/upsert data administration tools I haven't seen its equal anywhere else, especially for free. Aug 12, 2023 at 15:10

1 Answer 1

3

To get a copy running locally, here's the steps I fumbled through.

First, install Ubuntu, if needed. This answer applies to Ubuntu 22.04.3. I installed it using unattended mode in Virtualbox for this answer.

Next, download and extract the latest file from the installation notes. I used the ZIP version, but this should hardly matter which one you choose.

Now, get into terminal and log in as superuser:

~/$ su
Password:
/home/brianfear/#

You'll know you're root because of the # at the end of the prompt, instead of $.

Next, we may need to install some stuff. It doesn't hurt to run these commands multiple times (e.g. some of them may have already been installed).

apt install php8.1

apt install php8.1-soap

apt install php8.1-curl

After that, we have to copy the ~/Downloads/forceworkbench-53.0.0/workbench directory. Remember we're in superuser mode, so we need to use the appropriate home directory.

cp -r /home/brianfear/Downloads/forceworkbench-53.0.0/ /var/www/html/

PHP doesn't like missing required sources, so let's make an empty file.

mkdir /var/www/html/vendor
touch /var/www/html/vendor/autoinit.php

PHP 8 has removed the function get_magic_quotes_gpc(), so we need to update the source code.

find /var/www/html/workbench/ -type f | xargs sed -i  's/get_magic_quotes_gpc\(\)/false/g'

Or do this in an IDE. We're just replacing get_magic_quotes_gpc() with false, so the ternary operator will always take the false path. You can clean this up later if you'd like.

Now, you need to enable SOAP. Open /etc/php8.1/apache2/php.ini, find the line that reads ;extension=soap and remove the ;. Save your changes.

Now that we've done all this, you should be just about ready. Since we changed an ini file, we need to restart the server.

# systemctl restart apache2.server

If you've done all of this correctly, you should be able to click on this link: Local Workbench, and it'll take you to the login page.

I haven't tested every single page to see if there's any other missing dependencies, but I did test a number of pages, everything seems to be functional. If you get stuck or have other feedback, please feel free to reach out.

1
  • Thank you. I will try this out this weekend, and get back to you! Aug 18, 2023 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .