0

I wasted already hours to solve this "feature" here: Why Mobile Debugging does not work on MacOS13/XCode14/iOS16.4? Why no inspectable apps are shown in Safaris Develop-Menu?

Now today I wanted to dive into debugging but: surprise, surprise! Now NO simulators AT ALL are shown anymore in the darn Safari > Develop menu. I can't remember that I have changed anything since my last successful run with XCode 14.0.1 Simulator and iOS 16.0

The effect is different to:

  • the earlier issue had shown all the simulators I have started but NO inspectable app.
    • This old issue is solved already by downgrading to XCode 14.0.1 (iOS 16.0) which does not need a webview has to be marked as "inspectable" (which Salesforce is very likely not doing in the Chatter.app provided by them for mobile debugging)
  • the current issue does NOT show ANY simulators I start in Safari. Simply nothing at all.

Research on Google brought only old crap dating back year ago pointing me to use the Technology Preview of Safari.

Why Safari just stops from on day to another to show any Simulators in the Develop menu?

EDIT 1

This again is horrible for Windows users...

I solved it by uninstalling any versions of XCode and reinstalling 14.0.1. I still had 14.3.1 and 14.0.1 in parallel. Which worked fine last Friday.

I've renamed both XCode versions in the Application folder from just XCode to

  • XCode_14_0_1
  • XCode_14_3_1

Now after uninstall/reinstall I came up again with a plain "XCode" not having any version-suffix.

  • I have no idea if possible, but could this renaming kill the debuggability in Safari?
  • Is the parallel installation of two XCode versions an issue?

Maybe my solution is non-permanent and volatile. Therefore I will not post this as an answer and wait for some qualified Salesforce+Apple developers to clear up this mess.

Any ideas are welcome! I would like to understand how this fragile toolchain is supposed to work...

0

You must log in to answer this question.