0

I am trying to archive a published Knowledge Article using Salesforce flow. I tried using the standard Knowledge Action 'Archive online knowledge articles' for this purpose. However, when I try to use it, it prompts me to provide a list of Article Version Ids. When I try passing a list, it throws an error: 'The data type of the resource you entered isn't compatible.' Can anyone please explain what exact data needs to be passed as a parameter? Does the list have to be of some specific object or type?

enter image description here

I face the same issue when trying to Publish a Knowledge article using the standard Knowledge action in flow. I am not sure what exact data needs to be passed for the 'Article Version ID List'.

I tried with both KnowledgeFAQ_kav and KnowledgeArticleVersion and neither seems to work: enter image description here

It is taking only Record (Single) Variables and when I am trying to use any of the ones I created, it shows a list of all the related lookup fields except the ID: enter image description here

No matter what I choose, I keep seeing endless options of lookup fields and none of the options seem to work.

6
  • are you using the sobjectType that ends in __kav ?
    – cropredy
    Commented Jun 27, 2023 at 3:38
  • Yes, I tried using both KnowledgeFAQ__kav and KnowledgeArticleVersion and neither seems to work. I have edited the post to include screenshots for it as well.
    – it-nish
    Commented Jun 27, 2023 at 4:12
  • @it-nish what is the data type of the draftArticleIdList variable that you're passing in the first screenshot? Commented Jul 4, 2023 at 1:20
  • It is KnowledgeFAQ__kav
    – it-nish
    Commented Jul 4, 2023 at 15:43
  • were you able to find the solution for this ?
    – User6670
    Commented Jul 18, 2023 at 16:46

1 Answer 1

0

The solution that worked for me: use a For Loop explicitly. If I use a for loop and store the ids in a collection, then I can use that collection in this Knowledge flow action. However, if I try to use Get Records and store the values in a collection it doesn't work. For some reason, an extra step of for loop is needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .