23

I was happily using Workbench as usual then after dinner I started receiving error message "UNKNOWN ERROR: read error on connection to ec2-34-194-152-137.compute-1.amazonaws.com:6379" for any Query. I tried different api versions and different browsers to not avail. Anyone having this error?

Edit: It works properly if you choose to use Bulk CSV or Bulk XML and download file to see results.

16
  • 4
    This has been reported by multiple customers. I'll let you know as I have an update on this . Also see workbench.developerforce.com/help.php Thanks Jun 21, 2023 at 9:14
  • 4
    Welcome to users finding this question via search. Please do not post "I'm having the same problem" in answers or comments. If you have a solution to share, please check out How to Answer. Thanks!
    – David Reed
    Jun 21, 2023 at 15:41
  • 2
    Is there a Salesforce "known issue" for this? Jun 22, 2023 at 15:53
  • 1
    I did report it to Salesforce, but they said it's not their product. Jun 30, 2023 at 0:24
  • 2
    I find Salesforce Inspector as easy to use if not more easy than Workbench for doing queries.
    – fred
    Jun 30, 2023 at 9:48

4 Answers 4

2

For doing SOQL queries an alternative tool to use is Salesforce Inspector (a Chrome extension). It is very easy to use.

2
  • Salesforce Inspector does not work for me. I click on the extension icon and it goes back to the chrome web store. Jul 2, 2023 at 12:11
  • To use it there is a little arrow that appears on the right whenever you're on a Salesforce page.
    – fred
    Jul 3, 2023 at 10:02
2

26/06/2023 This solution did not work for me when I faced these issues again. So it may or may not work for you.

22/06/2023 I was facing a similar issue, I was able to resolve this issue by going to my User Settings and Revoking Workbench OAuth Apps setting. Attaching a screenshot here -- > enter image description here

28/06/2023 As a workaround you can use Bulk CSV options. I hope this helps enter image description here enter image description here

1
  • 2
    This did not work for me and continue to experience the same error.
    – rouqeOne
    Jun 22, 2023 at 21:01
1

Looking at the closed pull requests on the project's Github, the issue appears to be fixed now. Using the "List" option for "View As" appears to be working in my limited, independent testing (tested using API v57.0 and v58.0).

workbench.developerforce.com is hosted on Heroku (the "developerforce" instance from here on), which in turn uses Amazon's AWS (hence "amazonaws" appearing in the error message).

According to the pull requests, the issue was related to Redis v6 (developerforce appears to use a Heroku add-on, "Heroku Data for Redis", as a session store for operation across multiple compute resources, or "Dynos" in Heroku parlance) and making a TLS connection.

Heroku started requiring TLS for connections to its Redis add-on for all but the "mini" instance (where TLS is supposedly only suggested rather than required) when using Heroku Data for Redis v6. URLs and port numbers may have changed, and this add-on uses a self-signed cert (which required some additional changes in setting up the TLS connection from PHP, namely disabling peer verification).

There was also apparently some work that needed to be done because the session save handler (in the Redis driver that PHP provides?) isn't able to handle TLS connections yet.

Shoutout to Ryan Brainard for putting in the work on this.

1
  • Workbench is working for me! Thank you Ryan for solving the issue. Jul 13, 2023 at 9:56
0

If you are having problems with Workbench connection to a specific org where you can successfully login to that org directly, you might want to ask your admin (if you don't have permissions) to go to Setup > Apps > Connected Apps > Connected Apps OAuth Usage:

Connected App OAuth Usage

Click the "User Count" link against Workbench, find your username and hit the "Revoke" action.

This will then require you to re-authenticate against Workbench with your credentials, potentially fixing your problem.

2
  • 1
    Tried this and it did not work
    – user566047
    Jun 30, 2023 at 15:50
  • Fair enough, though it can help when problems arise so I'll leave it here for other solution seekers. So, if it's not the browser, the network, the credentials or credential-related state, that makes it sound like you've hit an issue in your org itself. Are you able to perform the equivalent of what you are doing through Workbench using the developer console, with the same credentials?
    – Phil W
    Jun 30, 2023 at 15:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .