While Deploying the Schedule Trigger Flow I am getting the following error :

This flow can't reference $Record because its trigger type is None. Change the trigger type, change the flow global variable, or remove the flow global variable from this flow.

I am using the below package.xml


I retrieved the flow using ANT from ORG1 and while Validating the the flow deployment in ORG2 I got the above error.

I also deactivated the flow version in ORG2 before doing the validation deployment, but still I am getting the error.

  • That error implies that the flow definition that you are trying to deploy has the incorrect type in it. Could you check what the processType attribute in the Flow metadata file is? Jun 6 at 11:48
  • I'd look to see what version of the MDAPI you are using in ANT and compare that against the Flow's version
    – cropredy
    Jun 6 at 15:34
  • I checked that flow version and that was the problem. It worked after changing the flow version in the package. @cropredy Jun 6 at 16:22

1 Answer 1


The Flow API Version was different. I retrieved the Flow with apiversion=46.0 whereas the flow apiversion = 57.0. I changed it to 57.0 and retrieved it and validated it again in ORG2 and this solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .