1

I'm trying to use Eclipse to create a new project. When I attempt to choose metadata components, I do not see any fields under the objects. When I expand the objects, all I see are workflows.

I've tried re-installing the Force.com IDE multiple times and it never seems to work.

Any ideas?

enter image description here

7
  • Do you have to use Eclipse? I'm not sure about your issue, but MavensMate is very good with Force.com mavensmate.com
    – EricSSH
    Jun 12, 2014 at 23:38
  • 1) identify your eclipse version + sandbox version; 2) edit your post to include a screen shot of how you are selecting metadata components.
    – cropredy
    Jun 13, 2014 at 0:52
  • I've tried using eclipse version 4.2 as well as 4.3. My sandbox version is Spring '14. Unfortunately I don't have enough reputation points to add a screenshot here. Jun 13, 2014 at 17:26
  • 1
    1) before doing the Component selection, did you try clicking the refresh schema button in the upper right of the dialog? 2) Please post your package.xml file contents into your original post
    – cropredy
    Aug 19, 2014 at 23:13
  • 1
    I did try the refresh button and it didn't fix the issue. However, the good news is that I finally fixed the problem this morning. To do this, I uninstalled all versions of Java on my machine, and deleted every Eclipse file, regardless of what folder it was in (since Eclipse writes to multiple locations). Then re-installed Java and Eclipse. Thank you to everyone for your ideas and help on this. Aug 21, 2014 at 16:37

2 Answers 2

2

I finally fixed the problem this morning. To do this, I uninstalled all versions of Java on my machine, and deleted every Eclipse file, regardless of what folder it was in (since Eclipse writes to multiple locations). Then re-installed Java and Eclipse.

0

I had the same problem and found a workaround:

To retrieve objects along with your custom metadata, you have to manually add necessary objects to your Eclipse package.xml file. For example, to retrieve a custom object MyObject__c (with all fields, validation rules, record types etc), you should add:

<types>
    <members>MyObject__c</members>
    <name>CustomObject</name>
</types>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.