2

Very possible that I edited some config without knowing, but within the page layout editor, all the fields to select by drag-and-drop have a hover pop-up that present information on the field. Oddly, just noticed that the data-type language is no longer in English.

Why, and how do I fix this?

Example:

enter image description here


Updates:

  • Confirmed that my user profile has Locale & Language set to English.
  • Might be of use if anyone is able to confirm that they do not see this issue too; realize it is unlikely that it is a issue global to Salesforce, but seems very odd that only the data type info would be in another language.
  • Reviewed the "Understanding Language, Locale, and Currency" help page, and not seeing anything that relates to this.

Major Update:

Just went back to confirm that the issue was still present, and oddly it is now in another language:

enter image description here

Also, the non-English language is ONLY present on the contact page layout, if I load another page layout, for example the account page layout, the data type is in English:

enter image description here

2
  • Have you checked the Locale and Language of your user account?
    – greenstork
    Jun 12, 2014 at 19:11
  • @greenstork: Just confirmed that my user profile has Locale & Language set to English; added this info to the question. Guessing the answer is likely this is specific to me, but I know for sure that the data type info was in English before, and seems a bit odd that only the data type info would be in a non-English language too.
    – blunders
    Jun 12, 2014 at 19:16

2 Answers 2

1

It is based on your user's locale. When I switched my locale to Japanese (Japan)

enter image description here

It changed my hover to:

enter image description here

Changing it back to English fixed it

enter image description here


My guess is that this is a bug in Salesforce. I'm not sure why your Locale would change the language only for the type. I would assume the Language would control that.

3
  • +1 Thanks, I confirmed that my user profile has Locale & Language set to English. Just went back to confirm that the issue was still present, and oddly it is now in another language; updated the question to reflect this; very, very odd.
    – blunders
    Jun 12, 2014 at 19:29
  • Yeah, at this point I am pretty sure this is a bug; the non-English language is ONLY present on the contact page layout, if I load another page layout, for example the account page layout, the data type is in English; also, add this info to the question.
    – blunders
    Jun 12, 2014 at 19:33
  • So, appear that the solution is to change the Locale & Language set from English, to another language, and then back to English; this based on me thinking this might force the configs to reset; currently works, posted this as an answer, will check it later to confirm it is still working. Thanks for the help!
    – blunders
    Jun 12, 2014 at 19:43
1

Appears that the answer is to change the Locale & Language set from English (that's what they were set to) both to another Language, then back; just be careful, since this will CHANGE the interface language, and if you're unable to read the language, it might be a challenge to set the Locale & Language settings back to English.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .