Trying to mass upload custom metadata type records using cmdt commands. The following was working but now it stopped. I keep getting this error: 'The column Name is not found on the custom metadata'. But according to docs I've read, the name column is needed for creating the label and name for the record. Please help... I am just confused why the Name column is suddenly a problem..

Sfdx force:cmdt:record:insert --filepath /Desktop/test.csv --typename test__mdt  --inputdir /Documents/main/default/objects --outputdir /Users/4530206/Documents/main/default/customMetadata

test_mdt has two fields: text__c and num__c

test.csv has three columns: Name, text__c, num__c

6 Answers 6


Similar to answer from Chris about the format. I was saving in Excel as CSV UTF-8 and this wasn't working. I tried just saving it using Excel CSV, with no other options, and it worked! I also had this problem couple years ago and then I was using Notepad++ and saving as UTF-8 worked. So guess it's also dependent on what program you are using to save your CSV file. Big nuisance!


@Dmns Check the encoding of your csv file, it must be UTF8. I had the exact same error because my csv file was encoded in UTF8-BOM, after conversion in UTF8 it worked !


Make sure your CSV file is separated by commas and not by semicolons, this solved the issue for me.


Please make sure that the csv files you are using for uploading custom metadata records has column for all the fields of the custom metadata even if that fields doesn't have any value on that record.


The Name field on a Custom Metadata Type is actually called DeveloperName in the background. When inserting records you'll need to use the field API names like you have for your custom fields. To fix this you will just need to update the column headers to DeveloperName not Name.

Here's a link to the documentation for this Custom Metadata Type__mdt Object Reference

  • 1
    I tried that as well and then receive the error "the column DeveloperName is not foundo n the custom metadata" ....
    – Dmns
    Commented May 26, 2023 at 12:40
  • Doesn't work neither for us
    – Charles dB
    Commented Jun 12, 2023 at 10:00
  • Name is right. DeveloperName is oddly incorrect in this instance. The column DeveloperName is not found on the custom metadata type...
    – rmarq423
    Commented Jun 26, 2023 at 23:50

I have the same error for Label and MasterLabel. I tried saving as CSV (Comma delimited) and CSV UTF-8 (Comma delimited) with the same result.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .