1

I created a record triggered flow and tried to create a formula which can check for a multi select picklist which I can use later in the flow. The formula is like this -

IF(INCLUDES( {!$Record.multiselect__c} , "abc"), "abc" + BR(), NULL)

The flow is running on create and update, I have tried before and after, but every time the formula returns NULL when I debug it add a the value "abc" to the multi select field.

I am not sure what I am doing wrong? Or this is not supposed to work?

Thanks

2
  • typo - no c at end of custom field? If it runs correctly in debug, but not "live", then perhaps the input use case is not the same or you have some other automation that clears the value
    – cropredy
    Commented May 5, 2023 at 15:44
  • It was just an example as I did not wanted to use the actual api name
    – SEuser
    Commented May 5, 2023 at 16:31

1 Answer 1

0

It could possibly be because the exact value needs to be specified when you use INCLUDES. For example, if one of the multiselect values is "abc" then the following formula would return as NULL:

IF(INCLUDES( {!$Record.multiselect__c} , "ab"), "abc", NULL)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .