3

I am attempting to load using Dataloader and I am running into a "CSV Error: Can't Read from CSV file" on every attempt.

Originally I successfully loaded some data without any error but now any csv I try to load, including the sample of test data csv that originally succeeded, returns this error "CSV Error: Can't Read from CSV file".

In the console i noticed the Dataloader is unsuccessfully looking for a mapping file. I didn't remove or move this mapping file, and technically he should not be looking for that specific mapping too.

What can i do?

1
  • 1
    Why would people downrate this question? It's clear. specific, and is related to Salesforce.
    – Jagular
    Sep 20, 2023 at 20:53

7 Answers 7

1

I just had the same thing happen. The mapping file was my own custom one that I had saved at an earlier import. Even though the current import was for a completely different object, Data Loader was still "remembering" and looking for the mapping file from before.

On closer inspection of the console error, I found that the file path was indeed NOT exactly correct to find the mapping file. It was looking one folder up from where the file was actually saved. I honestly do not recall if I had moved the mapping file when organizing all the import files, success logs etc. Regardless, by copying the "missing" mapping file up a level to where Data Loader was looking, I was able to move past the read error.

1

I got this bug while working with Dataloader 57.0.1.

It is no doubt a bug because in the console I see that it is trying to map columns with an earlier mapping file that had used for a completely different load. Strange is that, DL will continue to give you this error although you still are not at the step where it asks you to choose a mapping file or map manually.

Anyway, the way I got rid of this is to perform just a random export - which somehow made DL "forget" the mapping file and initialize successfully.

0

The way I resolved the error was by editing the "config.properties" file (located in the "/dataloader//configs" folder). In "config.properties" I change the value of the parameter "process.mappingFile=" to "\dataloader\\samples\conf\accountExtractMap.sdl". This sdl file is one of the examples that comes with dataloader. Then save the config file and reopen dataloader. Greetings

0

I just encountered this problem. I shut down the dataloader and restarted it. The error message did not recur when attempting to load the same csv file.

0

In the Salesforce Dataloader Settings, I removed the "-" from the following Setting:

"Other Delimiters for load operations (enter multiple values with no separator; for example, !+?):"

and clicked OK.

For me, that finally solved this problem.

0

Here's the translation of your message to English:

Hello, good morning, yes, good morning, I am currently in Colombia.

Looking at this error and also following mine, which I have seen from the console that Dataloader opens for us when we open it to do our work with data.

*

ERROR [main] ui.DataSelectionDialog handleCSVReadError (DataSelectionDialog.java:69) - CSV Error: Invalid CSV file format. Please select a different file.

Well! Looking at the problem for which I was looking for an optimal solution with the error presented when trying to upload records to Salesforce using Dataloader, it was a bit difficult to find a solution to this error.

I asked myself some questions,

  • What should a csv file look like? And it is like this:
    Name,Age,Profession
    Juan,34,Engineer
    Ana,28,Doctor
    Carlos,45,Professor

In this example, the first line is the header that indicates the names of the columns: Name, Age and Profession. The following lines represent the rows of the table, where each value separated by commas corresponds to a cell in the row.

Therefore, after asking myself this question and analyzing my document well, I noticed something very strange in it, and it was that at the moment I was trying to convert my excel(xlsx) file to the .csv version, I noticed that it was converting the files with ; and what we were looking for, was that this file was csv, meaning that it put my rows and columns separated with ,

So, first error found. Let's solve this, sometimes the configuration of our computer comes with some default values and makes that when we convert these files from Excel to csv, it generates this error and puts ; instead of comma(,) which is what we are looking for, so to solve this what I did was to press the Windows button and search for Region, Searching region for manage Salesforce Error with dataloader and csv files

After clicking there and opening the file, what I did was, modify the value that was presenting me error, the value that was presenting me error remember was (;)

Replace the ; for , for fixc the Dataloader Error with csv files So we must change that value, which is in the image with the number 2, for a comma (,) and ready we save and close, and now if we try to convert our original excel(xlsx) file to csv again, in this way it will now give us to be able to upload our files without this error being presented to us.

I hope my answer is useful to someone.

-1

Just ran into a similar issue where Dataloader was telling me I had a invalid file. In dataloader settings I checked "Read all CSV's with UTF-8 encoding" and this resolved the issue.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .