1

This is going to be a self-answered question, intended to fill in a knowledge gap that doesn't appear to be readily available anywhere else (at least not in any great detail)

Around 15:00EST on Friday, April 28th 2023, we started seeing an HTTP 420 error affecting seemingly every single type of Salesforce operation. This was happening very-frequently but not constantly, which resulted in much data-loss.

UPDATE The operations were limited to anything making an API request to Salesforce, which includes logging into the org; this was giving us the impression that the whole platform was affected, but operations entirely confined within the org seem to have been unaffected by the error.

2
  • Could you be more specific on what type of operation and where do you see the HTTP status code / response? (Please edit your question). We have many customers using Communities and none of them see this issue.
    – identigral
    May 1, 2023 at 16:00
  • 1
    We are seeing it affect requests from various APIs, even logging in to the org is being affected. (again, it's inconsistent but frequent, so not every API request is getting shut down, but a majority are) The incident I linked is the most-relevant response from Salesforce that I have yet been able to find (and they haven't provided any useful information on the Case I have opened with them) so I'm not saying that it's 100% related, and it might not be affecting all instances, but it's the best correlation that I have access to.
    – DanTheMan
    May 1, 2023 at 16:04

1 Answer 1

3

The error code itself seems to have originated from the Spring Framework; they had the 420 code to indicate a Method Failure, but Spring has since deprecated this code.

The Data Loader application is/was built using the Spring Framework, so it stands to reason that the error is coming from that somehow.

There is no direct confirmation or documentation from Salesforce about this error code, but they do have an open incident that matches the timeline, though it implies that the affected services are limited to Communities. (see attached photo)

I'm no stranger to Salesforce being cagey about widespread service disruption, and it seems that others have noticed that Salesforce has never really commented on this error in the past.

So for anyone else experiencing this issue at the same time as me, or in the future, hopefully this provides some kind of explanation / vindication.

UPDATE 1: After much back-&-forth with Salesforce Support, they ended up disabling the Salesforce Edge Network for our org.

Since then, we have experienced no further instances of ERROR_HTTP_420.

As of writing this, we have not been provided any explanation of this failure. We have a list of outstanding questions that we are pressuring them to answer, but we have yet to hear anything of substance from them.

Once we get any kind of details, I intend to update this post with more details for posterity & to be of more use for the community.


Incident Information - Status: Ongoing, Start Time: 7:50pm UTC, April 28th, Impacted Services: Communities

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .