0

The account object has several record types in my organization. There currently are two page layouts. The "account page layout" and the "plano de saude layout". However they are copies of eachother. I updated both of them. However still it is the original default layout (that you get when the organization is created) that is shown.

I already tried:

  • Untick, in your test area - "Enable secure and persistent browser caching to improve performance"
  • Switch between comfy & compact visualization mode
  • Go in incognito mode

Nothing works, any tips?

6
  • 1. Review your page layout assignment and ensure that the updated layouts are properly assigned by profile. 2. (Assuming you're on Lightning) Review the Lightning Record Page configuration. It's possible that you have a Dynamic Lightning Record Page that is pulling the fields directly from the object and bypassing your layouts - help.salesforce.com/s/… Apr 26, 2023 at 15:26
  • Thanks for the suggestions. However I already went to the account object, clicked profile assignment on the right top and the account layout that I changed has been assigned to all profiles. Even more, there is no layout that I didnt change. I dont know how it still accesses the default layout. It is a normal page layout, not lightning record.
    – ThaNoob
    Apr 27, 2023 at 7:03
  • Additional info: It does work on mobile. (I tried a different browser on desktop, did not help)
    – ThaNoob
    Apr 27, 2023 at 11:31
  • If the changes are saving (so you see them when you try to repeat the edit), but not displaying you still have a caching issue. In addition to the suggestions already posted, you can enable debug mode for your user and clear the caches for the page directly. This approach was needed a great deal when these features were new, and I'm finding are (fortunately) less and less useful. But it still comes up as helpful in times and places.
    – acrosman
    Aug 11, 2023 at 16:20
  • In addition to what you have tried, also confirm that the relevant profiles (including the profile for your username!) have read access to the page layout fields! Nov 9, 2023 at 3:26

1 Answer 1

2

This is a known issue: https://issues.salesforce.com/issue/a028c00000qQ26SAAS/page-layout-changes-not-displayed-unless-page-is-refreshed-in-lightning-experience

A workaround that they suggest is turn off "Enable secure and persistent browser caching to improve performance." This setting is found in Session Settings in Setup.

1
  • Did you try checking to see if Dynamic Forms was enabled like Tony Kirumba suggested? I recently had this be the issue with a page layout not updating. Oct 19, 2023 at 21:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .