17

I have recently began using MavensMate and I'm running into a problem where every time I save I have to refresh the metadata container. I have read through the documentation, but haven't been able to locate a solution in the documentation. The error I get is

Result: [OPERATION FAILED]: Resource  Not Found. Response content: [{u'errorCode': u'NOT_FOUND', u'message': u'Provided external ID field does not exist or is not accessible: <unknown>'}]

Again my only solution I have found so far was to refresh the metadata container after every time I save. Is there something I need to set inside the of the settings?

3
  • I'm assuming this is a Summer 14 Org, correct? Jun 10, 2014 at 23:46
  • Yup it sure is @DanielBallinger
    – EricSSH
    Jun 10, 2014 at 23:47
  • Did you check the API version of the file you're attempting to save? We saw an instance where one was set to API version 31 for some reason.
    – Phil B
    Jun 11, 2014 at 21:16

3 Answers 3

14

Fixed by setting mm_compile_with_tooling_api = false;

There is currently an open issue for this in the MavensMate Github : Error saving files to sandbox with Summer'14

4
  • My colleague was experiencing the same issue yesterday all day. Disabling the tooling API is not a resolution though :) Jun 10, 2014 at 23:19
  • 2
    It may not be, but its allowing me to actually get some work done :)
    – EricSSH
    Jun 10, 2014 at 23:24
  • I work with the tooling API disabled regularly due to some issues with the compiler the tooling API uses and haven't had much issue. Slightly slower, but certainly still a good tool. Jun 11, 2014 at 4:26
  • 1
    patch is available for that now, see github.com/joeferraro/MavensMate/issues/290 for discussion, patch github.com/joeferraro/mm/pull/25 Jun 26, 2014 at 18:15
1

In a nutshell, the tooling api documentation is extraordinarily basic, and doesn't cover response formats and a lot of expected behavior. So people try and guess stuff, and no surprise Salesforce changes stuff, again without documentation or notice.

There is a very extended discussion on github. At a high level, when updating an metadata member, you have to PATCH or POST depending on whether it's new to the metadata container. The current algorithm MM was using was to try post, and if it fails, pull out the correct id from the response and do a PATCH. With Summer '14 the POST response boofed and just returned

Old Response (with a totallly fake id)

[
  {
    "errorCode": "DUPLICATE_VALUE",
    "fields": [],
    "message": "duplicate value found: 400asdfasdfasdf1 duplicates value on record with id: 400asdfasdfasdf1"
  }
]

New Response

[
  {
    "errorCode": "DUPLICATE_VALUE",
    "fields": [],
    "message": "duplicate value found: <unknown> duplicates value on record with id: <unknown>"
  }
]

A patch is available, but hasn't yet been merged by the mm project collabators.

-1

Just go to mavensmate ----> Utilities ----> Reset Meta Data Container..

Its solved my problem..

1
  • Hi Sunil, Welcome to Stackexchange. If you re-read my question you will notice I bring that up, I believe this issue has been patched anyway
    – EricSSH
    Dec 16, 2014 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.