I am trying to access recordtypeid from Account record in a before context flow.The flow is not entering the insert condition criteria. After debugging i came to know that recordtypeid is causing the issue. [![Record.reocrdtypeid in Decision element][1]][1]

I have first removed 4th condition i.e recordtypeid it was working fine the insert criteria passed but after i add the recordtypeid it is returning false. I have tried with developername as well.

Its a record triggered flow which fires before create & update optimize for fast field updates.

  • Can you please help to add the error snapshot in flow-debug mode to understand the issue further more better?
    – Raj
    Commented Apr 13, 2023 at 14:14
  • is your custom label value a 15 char or 18 char ID?
    – cropredy
    Commented Apr 13, 2023 at 21:47
  • 18 character ID Commented Apr 14, 2023 at 6:23

1 Answer 1


It's the "optimize for fast field updates" that's causing the issue here. That precludes lookup references in both actions and conditions (at least as of API version 57), and record types are a kind of lookup. Switch to the other optimization mode and this issue should disappear.

  • for both create and update ?
    – cropredy
    Commented Apr 13, 2023 at 17:08
  • I believe so, though it's been a bit since I ran into this particular issue. It's not a matter of whether you're creating a new record or not, it's a matter of whether you're referencing any other records (e.g., by lookup). Commented Apr 13, 2023 at 17:18
  • But i need to run this flow in before context. Commented Apr 13, 2023 at 17:45
  • Since i am modifying the field on account it needs to happen in before context. Commented Apr 13, 2023 at 17:47
  • Then you're going to need to find some other non-lookup field to filter on, here unfortunately. (Formula fields don't work either, I've tried) Commented Apr 13, 2023 at 18:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .